Author Topic: For Non-Steam version?  (Read 988 times)

Dr. Schnellinger

  • Newbie
  • *
  • Posts: 6
For Non-Steam version?
« on: January 20, 2017, 12:50:13 PM »
Hi.

I don't know if this has been asked before but here I go:

Is there a way to use this mod for the Non-steam version?

potterman28wxcv

  • Hero Member
  • *****
  • Posts: 1124
Re: For Non-Steam version?
« Reply #1 on: January 20, 2017, 08:15:13 PM »
Yes. You can download Synergies from the official Synergies website http://www.synergiesmod.com/
And put the mod in your mod folder

Dr. Schnellinger

  • Newbie
  • *
  • Posts: 6
Re: For Non-Steam version?
« Reply #2 on: January 24, 2017, 08:26:54 AM »
Sorry, it's me again. The mod isn't working, there is no 'mod' folder, I created one and placed the mod there and nothing happens, I also tried placing the mod in the 'guts' folder and still, nothing happens. Perhaps I have to update the game?
Well, if so, what version should I get? Mine is 1.9.5.1

potterman28wxcv

  • Hero Member
  • *****
  • Posts: 1124
Re: For Non-Steam version?
« Reply #3 on: January 29, 2017, 08:31:10 AM »
Your mod folder is in the same place where you have your saves.

For me it's in C:\Users\mylogin\Documents\my games\runic games\torchlight 2\mods

Dr. Schnellinger

  • Newbie
  • *
  • Posts: 6
Re: For Non-Steam version?
« Reply #4 on: January 29, 2017, 10:47:28 AM »
Nope, is not working. Here's a screen capture.
Perhaps it doesn't work under WindowsXP 32-bit?


potterman28wxcv

  • Hero Member
  • *****
  • Posts: 1124
Re: For Non-Steam version?
« Reply #5 on: January 30, 2017, 09:49:21 AM »
What does your Torchlight 2 looks like when you launch it ? Does it launch you straight into the game, or do you have a first prompt asking you whether you want to run just Torchlight 2 or with mods ?

My guess is that you might have a very old version of Torchlight 2, when there wasn't any proper mod support yet.
I don't know what is the current version of Torchlight 2.. But you might want to check out how to update it

Dr. Schnellinger

  • Newbie
  • *
  • Posts: 6
Re: For Non-Steam version?
« Reply #6 on: January 30, 2017, 12:24:29 PM »
My version is 1.9.5.1, and yes, there is no prompt.

potterman28wxcv

  • Hero Member
  • *****
  • Posts: 1124
Re: For Non-Steam version?
« Reply #7 on: January 30, 2017, 05:16:00 PM »
That's why it doesn't work, you have a very old Torchlight 2 version.

Either you update Torchlight 2 to the latest one, either you download a very old version of Synergies (but then you won't have half the content of it)

Dr. Schnellinger

  • Newbie
  • *
  • Posts: 6
Re: For Non-Steam version?
« Reply #8 on: February 06, 2017, 11:43:15 AM »
Yep, what was the problem.

I updated to the version 1.25.5.2 and now the mod works. (Yay)

But I have to ask: Any chance that you will include the Zealot sounds on your next relase?
and some re-skin work on her? I'd like to see a skin that looks more like a human.

I love Zealots (When they're friendly)
This one is cool as well, but.. uhm.. she's muted. I liked to hear her "Muhahaha" on TL1 XD

potterman28wxcv

  • Hero Member
  • *****
  • Posts: 1124
Re: For Non-Steam version?
« Reply #9 on: February 07, 2017, 01:33:28 PM »
Yep, what was the problem.

I updated to the version 1.25.5.2 and now the mod works. (Yay)

But I have to ask: Any chance that you will include the Zealot sounds on your next relase?
and some re-skin work on her? I'd like to see a skin that looks more like a human.

I love Zealots (When they're friendly)
This one is cool as well, but.. uhm.. she's muted. I liked to hear her "Muhahaha" on TL1 XD
Salan is the only one working on Synergies.

But even then, the Zealot is not part of Synergies. It must be from one of your other mods